воскресенье, 14 марта 2010 г.

Google Gears под linux

Сабж живет здесь: gears.google.com. О нем знает вики. См. линки в вики и узнаете много нового.

Но в линуксе не ставится, грязно ругаясь: "Google Gears" could not be installed because it is not compatible with your Firefox build type (Linux_x86-gcc3). Грязно - это потому что сабж собран в 32-бит версии, но выдает себя за 64-битного.

Или правим версию целевой платформы в install.rdf, или для iceweasel 3.5.8 работающий сабж можно взять здесь:
wget "http://gears.googlecode.com/issues/attachment?aid=-8070727757150286122&name=gears-linux-new.xpi"

Результат можно проверить, посмотрев примеры.

Комментариев нет:


(C) Alexey Pechnikov aka MBG, mobigroup.ru